Skip to main content
Pure1 Support Portal

Compatibility: vSphere Plugin

Pure Storage has TWO different vSphere Plugins. The old one that is no longer being updated that is for the flash/flex vSphere Client and a new one that is only for the HTML-5 vSphere Client. The HTML-5 plugin is the only plugin that will be enhanced moving forward. These are separate plugins that can be installed to the same vCenter at once, but still both need to be installed one at a time. One installation does not install both.

HTML-5 vSphere Client Plugin

Flash/Flex vSphere Web Client Plugin

  • Included on the FlashArray (if your array does not have the proper plugin version, contact support at support@purestorage.com)
  • vCenter 5.5 or later
  • Purity version 4.6 or later
  • FlashArray 400 Series
  • FlashArray//M Series
  • FlashArray//XSeries
Plugin version vCenter Version Purity Version Supported
4.2.0 (HTML-5) 6.5 Update 2 or higher, 6.7 GA or higher 4.10.x and higher
4.1.0 (HTML-5) 6.5 Update 2 or higher, 6.7 GA or higher 4.10.x and higher
4.0.0 (HTML-5) 6.5 Update 2 or higher, 6.7 GA or higher 4.10.x and higher
3.1.3 (Flash) 5.5 (all updates), 6.0 (all updates), 6.5** (all updates), 6.7 (all updates) 4.8.x and higher
3.1.2 (Flash) 5.5 (all updates), 6.0 (all updates), 6.5** (all updates), 6.7 (all updates) 4.8.x and higher
3.1.1 (Flash) 5.5 (all updates), 6.0 (all updates), 6.5** (all updates), 6.7 (all updates) 4.8.x and higher
3.1.0 (Flash) 5.5 (all updates), 6.0 (all updates), 6.5** (all updates), 6.7 (all updates) 4.5.x and higher
3.0.0 (Flash) 5.5 (all updates), 6.0 (all updates), 6.5** (all updates) 4.5.x and higher
2.5.1 (Flash) 5.5 (all updates), 6.0 (all updates), 6.5 (all updates) 4.5.x through 4.10.x
2.0.11 (Flash) 5.1 (all updates), 5.5 (all updates), 6.0 (GA through U2) 4.0.x through 4.7.x
2.0.10 (Flash) 5.1 (all updates), 5.5 (all updates), 6.0 (GA through U1) 4.0.x through 4.7.x
2.0.6 (Flash) 5.1 (all updates), 5.5 (all updates), 6.0 (GA through U1) 4.0.x through 4.6.x
2.0.0 (Flash) 5.1 (all updates), 5.5 (all updates) 4.0.x through 4.6.x

 

NOTE: The plugin requires TLS 1.1+ support, so vCenter 6.0 U1 and earlier must be upgraded to JDK 1.8. vCenter 6.0 U2 and later works out of the box as it has the correct JDK version.

 

**NOTE: The Register VASA Provider feature does not work with vCenter 6.5 Update 2 due to a bug in the JDK version in that vCenter release. Manual VASA registration is therefore required,