Skip to main content
Pure1 Support Portal

vROPs 1.x Management Pack Release Notes

Release Timeline

The following table outlines the release status and release date for the most recent release. 

Management Pack Version Release Status Release Date Supported Purity Versions Supported vROPs Versions
1.0.152 Available for download December 2017 4.7.x - 5.0.x 6.7, 7.0, & 7.5
1.0.151 Unavailable March 2017 4.7.x - 4.10.x 6.7, 7.0, & 7.5
1.0.139 Unavailable December 2016 4.6.x - 4.9.x 6.0 - 6.5

Pure Storage Management Pack 1.0.152 - Release Notes

Release Date: December, 2017

New in this Release

  • Support for Purity 5.0.x

    To avoid any disruption in functionality, we recommend upgrading the Pure Storage vROPs Management Pack before upgrading the FlashArray to Purity 5.0.0.

Pure Storage Management Pack 1.0.151 - Release Notes

Release Date: March, 2017

New in this Release

  • Workaround for compatibility with Cisco UCS vROPs management pack

    This release enforces TLS version 1.2 for plugin communications with a FlashArray. The Pure Storage vROPs Management Pack release contains a workaround to strictly enforce the usage of TLS version 1.2 for all communications between the Management Pack and the FlashArray.

    Why is this release necessary? When attempting to connect to a Cisco UCS server, the Cisco UCS vROPs management pack resets the global Java Virtual Machine (JVM) TLS protocol options to 1.0. This setting forces all vROPs management packs installed on the vROPs server (including the Pure Storage vROPs Management Pack) to use TLS version 1.0 for all secure communications to their respective appliances.

    However, since TLS 1.0 is no longer a secure protocol, Purity versions 4.7.0 and higher do not support TLS 1.0. Therefore our previous vROPs Management Packs cannot connect to a FlashArray running Purity version 4.7.0 or later. This Management Pack version (or higher) is required.

    Notes:

    • Other plugins: This workaround does not affect any other vROPs ps management packs installed on the same vROPs server instance, meaning all other vROPs management packs can continue to use TLS version 1.0 for all communication.

Pure Storage Management Pack 1.0.139 - Release Notes

Release Date: December, 2016

New in this Release

  • Support for IPv6
    Requires Purity 4.9.0 or higher, vSphere 6.0 or higher, and vROPs server 6.x. The customer must ensure that their 6.x version of the vROPs server supports IPv6.
    When an IPv6 IP address is configured in the vROPs Management Pack, the address must be entered enclosed in square brackets. For example: [2015:0db8:85a3:0042:1000:8a2e:0360:7334]

Requirements

  • VMware vRealize Operations Management 6.x
  • FlashArray FA-4xx or FlashArray//M
  • Purity Operation Environment 4.6 or later
    Note: IPv6 support requires Purity 4.9.0 or higher (as well as a vCenter Server with IPv6 support).
  • Full functionality only requires READ ONLY access to the FlashArray. FlashArray administrative credentials are not required.

Troubleshooting

  • Management Pack not appearing
    The Management Pack is installed correctly, but even after waiting a few minutes, I am not able to see the Management Pack in vRealize.
    Solution: Verify that you have the correct set of permissions to view the Management Pack. Log in to vRealize with a vRealize administrator account.
  • Malformed URL error message
    If an IPv6 address is incorrect or is not enclosed in square brackets, when the user clicks the Test Connection button or Save Settings button, an error message is seen: Unable to establish a valid connection to the target system. Connection failed -- Malformed URL encountered