Skip to main content
Pure Technical Services

Pure Storage Plugin for vRealize Orchestrator 7 Release Notes

Currently viewing public documentation. Please login to access the full scope of documentation.

 

Version 3.5.0

Support

  • vRealize Orchestrator 7.2+ is supported, 7.4 and later is recommended
  • FA Purity 4.10.x and later
  • FB Purity 3.0.x and later
  • vVol workflows required vCenter 6.5 and later and Purity 5.3.6 and later

What's New

  • Integrated Pure1 authentication
  • Pure1 workflows for authentication, tagging, provisioning, and array registration
  • vVol workflows are now integrated into the plugin
  • Volume group objects are integrated into plugin
  • FlashBlades can now be authenticated into the plugin
  • QoS configuration added to workflows for volumes and volume groups.

Resolved Issues

  • Volume membership of protection group fails when a volume is in a destroyed protection group
  • Improved handling of vVol workflows
  • Pure1 registration now places array in correct Pure1 organizations
  • FlashArray connection update updates the connection into the correct Pure1 organization
  • Provisioning skips hosts in maintenance mode

Known Problems

  • No support for vRealize 8.x--there will be a new release shortly for this support
  • No support for FlashArray REST 2.x