Skip to main content
Pure1 Support Portal

Enable TLS 1.1 and TLS 1.2 for VSS plugin 1.0.2

Applies to: Windows Server 2008R2

Problem

The "Pure Storage VSS Hardware Provider Guide Version 1.0.2" has the following note:
"Windows Server 2008 R2 by default does not support TLS 1.1 or higher. Manually enable TLS 1.1 or TLS 1.2 on the Windows Server."

Solution

To manually enable TLS 1.1 and/or TLS 1.2 install the update and follow the instructions to modify the registry from Microsoft KB3140245 (https://support.microsoft.com/en-us/kb/3140245).