Skip to main content
Pure Technical Services

Windows PowerShell Version Support for the FlashArray SDK

Currently viewing public documentation. Please login to access the full scope of documentation.

This article applies to all versions of the PowerShell SDK. 

The FlashArray PowerShell SDK version 1.x works with all 64-bit versions of Windows that support .NET 4.5, Windows PowerShell 3.0 to 5.1.

The FlashArray PowerShell SDK version 2.x works with all 64-bit versions of Windows that support .Net Core 2.1, MacOS and Linux PowerShell versions 5.1 and later.

Both SDK versions can be used from Windows Clients or Server editions. SDK version 2 can also be used on MacOS and Linux platforms supported by PowerShell.

Please refer to the Release Notes published here for the latest operating system and PowerShell version compatibility information.

The 1.x and 2.x versions of the SDK can be installed and run side-by-side on the same Windows computer in individual PowerShell sessions. This is not possible on a MacOS or Linux computer since those operating systems are not supported by PowerShell version 5.1 or SDK version 1.x.

To determine what version of Windows PowerShell that is installed in your environment, open up a Windows PowerShell session and type $PSVersionTable.

This will show all details as seen in the screenshots below depending on what version you have installed. The most important Value to check is PSVersion. 

The version below shows version 5.1.20175.1000. 

5.1-version.png

The version below shows version 7.0.3.

7-version.png